ObjectTableSelect Method (Guid, Boolean, Boolean) |
Select or deselects a single object.
Namespace:
Rhino.DocObjects.Tables
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Select(
Guid objectId,
bool select,
bool syncHighlight
)
Public Function Select (
objectId As Guid,
select As Boolean,
syncHighlight As Boolean
) As Boolean
Parameters
- objectId
- Type: SystemGuid
Id of object to select. - select
- Type: SystemBoolean
If true, the object will be selected, if false, it will be deselected. - syncHighlight
- Type: SystemBoolean
If true, then the object is highlighted if it is selected
and unhighlighted if is not selected.
Return Value
Type:
Booleantrue on success, false on failure.
See Also