Click or drag to resize

ObjectTableUnlock Method (ObjRef, Boolean)

If objref.Object().IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Unlock(
	ObjRef objref,
	bool ignoreLayerMode
)

Parameters

objref
Type: Rhino.DocObjectsObjRef
reference to locked object to unlock.
ignoreLayerMode
Type: SystemBoolean
if true, the object will be unlocked even if it is on a layer that is locked or off.

Return Value

Type: Boolean
true if the object was successfully unlocked.
See Also