ObjectTableUnlock Method (Guid, Boolean) |
If Object().IsLocked() is true, then the object will be returned to normal (visible and selectable) mode.
Namespace:
Rhino.DocObjects.Tables
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Unlock(
Guid objectId,
bool ignoreLayerMode
)
Public Function Unlock (
objectId As Guid,
ignoreLayerMode As Boolean
) As Boolean
Parameters
- objectId
- Type: SystemGuid
Id of locked object to unlock. - ignoreLayerMode
- Type: SystemBoolean
if true, the object will be unlocked even if it is on a layer that is locked or off.
Return Value
Type:
Booleantrue if the object was successfully unlocked.
See Also