ObjectTableModifyAttributes Method (ObjRef, ObjectAttributes, Boolean) |
Modifies an object's attributes. Cannot be used to change object id.
Namespace:
Rhino.DocObjects.Tables
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool ModifyAttributes(
ObjRef objref,
ObjectAttributes newAttributes,
bool quiet
)
Public Function ModifyAttributes (
objref As ObjRef,
newAttributes As ObjectAttributes,
quiet As Boolean
) As Boolean
Parameters
- objref
- Type: Rhino.DocObjectsObjRef
reference to object to modify. - newAttributes
- Type: Rhino.DocObjectsObjectAttributes
new attributes. - quiet
- Type: SystemBoolean
if true, then warning message boxes are disabled.
Return Value
Type:
Booleantrue if successful.
See Also