Click or drag to resize

ObjectTableModifyAttributes Method (RhinoObject, ObjectAttributes, Boolean)

Modifies an object's attributes. Cannot be used to change object id.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool ModifyAttributes(
	RhinoObject obj,
	ObjectAttributes newAttributes,
	bool quiet
)

Parameters

obj
Type: Rhino.DocObjectsRhinoObject
object to modify.
newAttributes
Type: Rhino.DocObjectsObjectAttributes
new attributes.
quiet
Type: SystemBoolean
if true, then warning message boxes are disabled.

Return Value

Type: Boolean
true if successful.
See Also