Click or drag to resize

ObjectTableAddPolyline Method (IEnumerablePoint3d, ObjectAttributes)

Adds a polyline object to Rhino.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddPolyline(
	IEnumerable<Point3d> points,
	ObjectAttributes attributes
)

Parameters

points
Type: System.Collections.GenericIEnumerablePoint3d
A Polyline; a list, an array, or any enumerable set of Point3d.
attributes
Type: Rhino.DocObjectsObjectAttributes
attributes to apply to line.

Return Value

Type: Guid
A unique identifier for the object.
See Also