Click or drag to resize

ObjectTableTransform Method (RhinoObject, Transform, Boolean)

Constructs a new object that is the transformation of the existing object and deletes the existing object if deleteOriginal is true.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid Transform(
	RhinoObject obj,
	Transform xform,
	bool deleteOriginal
)

Parameters

obj
Type: Rhino.DocObjectsRhinoObject
Rhino object to transform. This object will be deleted if deleteOriginal is true.
xform
Type: Rhino.GeometryTransform
transformation to apply.
deleteOriginal
Type: SystemBoolean
if true, the original object is deleted if false, the original object is not deleted.

Return Value

Type: Guid
Id of the new object that is the transformation of the existing_object. The new object has identical attributes.
Remarks
If the object is locked or on a locked layer, then it cannot be transformed.
See Also