Click or drag to resize

ObjectTableDelete Method (RhinoObject, Boolean)

Deletes object from document. The deletion can be undone by calling UndeleteObject().

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Delete(
	RhinoObject obj,
	bool quiet
)

Parameters

obj
Type: Rhino.DocObjectsRhinoObject
The object to delete.
quiet
Type: SystemBoolean
If false, a message box will appear when an object cannot be deleted.

Return Value

Type: Boolean
true on success, false on failure.
See Also