Click or drag to resize

ObjectTableAddCurve Method (Curve, ObjectAttributes)

Adds a curve object to Rhino.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddCurve(
	Curve curve,
	ObjectAttributes attributes
)

Parameters

curve
Type: Rhino.GeometryCurve
A curve. A duplicate of this curve is added to Rhino.
attributes
Type: Rhino.DocObjectsObjectAttributes
Attributes to apply to curve.

Return Value

Type: Guid
A unique identifier for the object.
See Also