Click or drag to resize

ObjectTableAdd Method (GeometryBase)

Adds geometry that is not further specified.

This is meant, for example, to handle addition of sets of different geometrical entities.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid Add(
	GeometryBase geometry
)

Parameters

geometry
Type: Rhino.GeometryGeometryBase
The base geometry. This cannot be null.

Return Value

Type: Guid
The new object ID on success.
Exceptions
ExceptionCondition
ArgumentNullExceptionIf geometry is null.
See Also