Click or drag to resize

CommonComponentTableT Class

Provides a base table type that encompasses all document tables, both in RhinoDoc and File3dm.
Inheritance Hierarchy

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class CommonComponentTable<T> : ICommonComponentTable<T>, 
	IReadOnlyCollection<T>, IEnumerable<T>, IEnumerable, ICollection<T>, IList<T>, 
	IReadOnlyList<T>
where T : ModelComponent

Type Parameters

T
A model component.

The CommonComponentTableT type exposes the following members.

Properties
  NameDescription
Public propertyComponentType
Returns the actual component type of a table.
Public propertyCount
Returns the count of all items, including deleted ones.
Top
Methods
  NameDescription
Public methodClear
Marks all items as deleted.
Public methodDelete
Deletes an item. Items that are deleted are still keeping their space, but the 'IsDeleted' flag is checked.
Public methodFindId
Uses the guid to find a model component. Deleted objects cannot be found by id. The guid is the value that is stored in the .Id property. In a single document, no two active objects have the same guid. If an object is replaced with a new object, then the guid persists. For example, if the _Move command moves an object, then the moved object inherits its guid from the starting object. If the Copy command copies an object, then the copy gets a new guid. This guid persists through file saving/opening operations. This function will not find grip objects.
Public methodGetEnumerator
Returns the enumerator that yields all items.
Top
See Also