Click or drag to resize

File3dmCommonComponentTableT Class

Provides a base table type that is shared among all File3dm tables.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableT
    Rhino.FileIOFile3dmCommonComponentTableT
      More...

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class File3dmCommonComponentTable<T> : CommonComponentTable<T>, 
	ICollection<T>, IEnumerable<T>, IEnumerable
where T : ModelComponent

Type Parameters

T
A model component.

The File3dmCommonComponentTableT type exposes the following members.

Properties
Methods
  NameDescription
Public methodAdd
Adds an item.
Public methodDelete(T)
Flags a component as deleted.
(Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32)
Flags a component as deleted.
Public methodDump
Prepares a text dump of object table.
Top
See Also
Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableT
    Rhino.FileIOFile3dmCommonComponentTableT
      Rhino.FileIOFile3dmDimStyleTable
      Rhino.FileIOFile3dmGroupTable
      Rhino.FileIOFile3dmHatchPatternTable
      Rhino.FileIOFile3dmInstanceDefinitionTable
      Rhino.FileIOFile3dmLayerTable
      Rhino.FileIOFile3dmLinetypeTable
      Rhino.FileIOFile3dmMaterialTable
      Rhino.FileIOFile3dmObjectTable