File3dmInstanceDefinitionTable Class |
Namespace: Rhino.FileIO
The File3dmInstanceDefinitionTable type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentType |
Returns InstanceDefinition.
(Overrides CommonComponentTableTComponentType.) |
![]() | Count |
Returns the count of all items, including deleted ones.
(Inherited from CommonComponentTableT.) |
Name | Description | |
---|---|---|
![]() | Add(T) |
Adds an item.
(Inherited from File3dmCommonComponentTableT.) |
![]() | Add(String, String, Point3d, IEnumerableGeometryBase) |
Adds an instance definition to the instance definition table.
|
![]() | Add(String, String, Point3d, GeometryBase, ObjectAttributes) |
Adds an instance definition to the instance definition table.
|
![]() | Add(String, String, Point3d, IEnumerableGeometryBase, IEnumerableObjectAttributes) |
Adds an instance definition to the instance definition table.
|
![]() | Add(String, String, String, String, Point3d, IEnumerableGeometryBase, IEnumerableObjectAttributes) |
Adds an instance definition to the instance definition table.
|
![]() | AddLinked |
Adds a linked instance definition to the instance definition table.
|
![]() | Clear |
Marks all items as deleted.
(Inherited from CommonComponentTableT.) |
![]() | Delete(T) |
Flags a component as deleted.
(Inherited from File3dmCommonComponentTableT.) |
![]() | Delete(Int32) |
Flags a component as deleted.
(Inherited from File3dmCommonComponentTableT.) |
![]() | Dump | Prepares a text dump of object table. (Inherited from File3dmCommonComponentTableT.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | FindId |
Uses the guid to find a model component. Deleted objects cannot be found by id.
The guid is the value that is stored in the .Id property.
In a single document, no two active objects have the same guid. If an object is
replaced with a new object, then the guid persists. For example, if the _Move command
moves an object, then the moved object inherits its guid from the starting object.
If the Copy command copies an object, then the copy gets a new guid. This guid persists
through file saving/opening operations. This function will not find grip objects.
(Inherited from CommonComponentTableT.) |
![]() | FindName |
Finds an InstanceDefinitionGeometry given its name.
|
![]() | FindNameHash |
Finds a InstanceDefinitionGeometry given its name hash.
|
![]() | GetEnumerator |
Returns the enumerator that yields all items.
(Inherited from CommonComponentTableT.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |