Click or drag to resize

File3dmObjectTable Class

Represents a simple object table for a file that is open externally.

This class mimics Rhino.DocObjects.Tables.ObjectTable while providing external access to the file.

Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableFile3dmObject
    Rhino.FileIOFile3dmCommonComponentTableFile3dmObject
      Rhino.FileIOFile3dmObjectTable

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmObjectTable : File3dmCommonComponentTable<File3dmObject>, 
	IEnumerable<File3dmObject>, IEnumerable

The File3dmObjectTable type exposes the following members.

Properties
Methods
  NameDescription
Public methodAdd(File3dmObject)
Duplicates the object, then adds a copy of the object to the document.
(Overrides File3dmCommonComponentTableTAdd(T).)
Public methodAdd(GeometryBase, ObjectAttributes)
Duplicates the object, then adds a copy of the object to the document.
Public methodAddAngularDimension(AngularDimension)
Adds a angular dimension object to the 3dm file object table.
Public methodAddAngularDimension(AngularDimension, ObjectAttributes)
Adds a angular dimension object to the 3dm file object table.
Public methodAddArc(Arc)
Adds a curve object to the document representing an arc.
Public methodAddArc(Arc, ObjectAttributes)
Adds a curve object to the document representing an arc.
Public methodAddBrep(Brep)
Adds a brep object to Rhino.
Public methodAddBrep(Brep, ObjectAttributes)
Adds a brep object to Rhino.
Public methodAddCircle(Circle)
Adds a curve object to the document representing a circle.
Public methodAddCircle(Circle, ObjectAttributes)
Adds a curve object to the document representing a circle.
Public methodAddClippingPlane(Plane, Double, Double, IEnumerableGuid)
Adds a clipping plane object to Rhino.
Public methodCode exampleAddClippingPlane(Plane, Double, Double, Guid)
Adds a clipping plane object to Rhino.
Public methodAddClippingPlane(Plane, Double, Double, IEnumerableGuid, ObjectAttributes)
Adds a clipping plane object to Rhino.
Public methodAddCurve(Curve)
Adds a curve object to the table.
Public methodAddCurve(Curve, ObjectAttributes)
Adds a curve object to the table.
Public methodAddEllipse(Ellipse)
Adds a curve object to the document representing an ellipse.
Public methodAddEllipse(Ellipse, ObjectAttributes)
Adds a curve object to the document representing an ellipse.
Public methodAddExtrusion(Extrusion)
Adds an extrusion object to Rhino.
Public methodAddExtrusion(Extrusion, ObjectAttributes)
Adds an extrusion object to Rhino.
Public methodAddHatch(Hatch)
Adds a hatch to the document.
Public methodAddHatch(Hatch, ObjectAttributes)
Adds a hatch to the document.
Public methodAddInstanceObject(InstanceReferenceGeometry)
Adds an instance reference geometry object to the table.
Public methodAddInstanceObject(InstanceReferenceGeometry, ObjectAttributes)
Adds an instance reference geometry object to the table.
Public methodAddInstanceObject(Int32, Transform)
Adds an instance reference geometry object to the table.
Public methodAddInstanceObject(Int32, Transform, ObjectAttributes)
Adds an instance reference geometry object to the table.
Public methodAddLeader(IEnumerablePoint3d)
Adds an annotation leader to the document. This overload is only provided in the Rhino SDK.
Public methodAddLeader(Plane, IEnumerablePoint2d)
Adds an annotation leader to the document.
Public methodAddLeader(String, IEnumerablePoint3d)
Adds an annotation leader to the document. This overload is only provided in the Rhino SDK.
Public methodAddLeader(Plane, IEnumerablePoint2d, ObjectAttributes)
Adds an annotation leader to the document.
Public methodAddLeader(String, Plane, IEnumerablePoint2d)
Adds an annotation leader to the document.
Public methodAddLeader(String, Plane, IEnumerablePoint2d, ObjectAttributes)
Adds an annotation leader to the document.
Public methodAddLine(Line)
Adds a line object to Rhino.
Public methodAddLine(Line, ObjectAttributes)
Adds a line object to Rhino.
Public methodAddLine(Point3d, Point3d)
Adds a line object to Rhino.
Public methodAddLine(Point3d, Point3d, ObjectAttributes)
Adds a line object to Rhino.
Public methodAddLinearDimension(LinearDimension)
Adds a linear dimension to the 3dm file object table.
Public methodAddLinearDimension(LinearDimension, ObjectAttributes)
Adds a linear dimension to the 3dm file object table.
Public methodAddMesh(Mesh)
Adds a mesh object to Rhino.
Public methodAddMesh(Mesh, ObjectAttributes)
Adds a mesh object to Rhino.
Public methodAddOrdinateDimension(OrdinateDimension)
Adds an ordinate dimension object to the 3dm file object table.
Public methodAddOrdinateDimension(OrdinateDimension, ObjectAttributes)
Adds an ordinate dimension object to the 3dm file object table.
Public methodAddPoint(Point3d)
Adds a point object to the table.
Public methodAddPoint(Point3f)
Adds a point object to the document.
Public methodAddPoint(Point3d, ObjectAttributes)
Adds a point object to the document.
Public methodAddPoint(Point3f, ObjectAttributes)
Adds a point object to the document.
Public methodAddPoint(Double, Double, Double)
Adds a point object to the table.
Public methodAddPointCloud(IEnumerablePoint3d)
Adds a point cloud object to the document.
Public methodAddPointCloud(PointCloud)
Adds a point cloud object to the document.
Public methodAddPointCloud(IEnumerablePoint3d, ObjectAttributes)
Adds a point cloud object to the document.
Public methodAddPointCloud(PointCloud, ObjectAttributes)
Adds a point cloud object to the document.
Public methodAddPoints(IEnumerablePoint3d)
Adds multiple points to the document.
Public methodAddPoints(IEnumerablePoint3f)
Adds multiple points to the document.
Public methodAddPoints(IEnumerablePoint3d, ObjectAttributes)
Adds multiple points to the document.
Public methodAddPoints(IEnumerablePoint3f, ObjectAttributes)
Adds multiple points to the document.
Public methodAddPolyline(IEnumerablePoint3d)
Adds a polyline object to Rhino.
Public methodAddPolyline(IEnumerablePoint3d, ObjectAttributes)
Adds a polyline object to Rhino.
Public methodAddRadialDimension(RadialDimension)
Adds a radial dimension object to the 3dm file object table.
Public methodAddRadialDimension(RadialDimension, ObjectAttributes)
Adds a radial dimension object to the 3dm file object table.
Public methodAddSphere(Sphere)
Adds a surface object to the document representing a sphere.
Public methodAddSphere(Sphere, ObjectAttributes)
Adds a surface object to the document representing a sphere.
Public methodAddSubD(SubD)
Adds a SubD to the document
Public methodAddSubD(SubD, ObjectAttributes)
Adds a SubD to the document
Public methodAddSurface(Surface)
Adds a surface object to Rhino.
Public methodAddSurface(Surface, ObjectAttributes)
Adds a surface object to Rhino.
Public methodAddText(Text3d)
Adds an annotation text object to the document.
Public methodAddText(Text3d, ObjectAttributes)
Adds an annotation text object to the document.
Public methodAddText(String, Plane, Double, String, Boolean, Boolean)
Adds an annotation text object to the document.
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, ObjectAttributes)
Adds an annotation text object to the document.
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, TextJustification)
Adds an annotation text object to the document.
Public methodAddText(String, Plane, Double, String, Boolean, Boolean, TextJustification, ObjectAttributes)
Adds an annotation text object to the document.
Public methodAddTextDot(TextDot)
Adds a text dot object to the table.
Public methodAddTextDot(String, Point3d)
Adds a text dot object to the table.
Public methodAddTextDot(TextDot, ObjectAttributes)
Adds a text dot object to the table.
Public methodAddTextDot(String, Point3d, ObjectAttributes)
Adds a text dot object to the table.
Public methodDelete(Guid)
Deletes object from document.
Public methodDelete(IEnumerableGuid)
Deletes a collection of objects from the document.
Public methodFindByGroup
Finds all File3dmObject that are in a given group.
Public methodFindByLayer(Layer)
Finds all File3dmObject that are in a given layer.
Public methodFindByLayer(String)
Finds all File3dmObject that are in a given layer.
Public methodGetBoundingBox
Gets the bounding box containing every object in this table.
Public methodGetEnumerator
Returns an enumerator that yields all objects in this document. Like in Rhino, this includes lights. Unlike in Rhino, however, all lights are returned in the end of the list.
(Overrides CommonComponentTableTGetEnumerator.)
Top
See Also