File3dmObjectTableAddCurve Method (Curve, ObjectAttributes) |
Adds a curve object to the table.
Namespace:
Rhino.FileIO
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Guid AddCurve(
Curve curve,
ObjectAttributes attributes
)
Public Function AddCurve (
curve As Curve,
attributes As ObjectAttributes
) As Guid
Parameters
- curve
- Type: Rhino.GeometryCurve
A duplicate of this curve is added to Rhino. - attributes
- Type: Rhino.DocObjectsObjectAttributes
Attributes to apply to curve.
Return Value
Type:
GuidA unique identifier for the object.
See Also