Click or drag to resize

File3dmObjectTableAddInstanceObject Method (Int32, Transform)

Adds an instance reference geometry object to the table.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.5
Syntax
public Guid AddInstanceObject(
	int instanceDefinitionIndex,
	Transform instanceXform
)

Parameters

instanceDefinitionIndex
Type: SystemInt32
The index of the instance definition geometry object.
instanceXform
Type: Rhino.GeometryTransform
The transformation.

Return Value

Type: Guid
A unique identifier for the object.
See Also