Click or drag to resize

File3dmObjectTableAddText Method (String, Plane, Double, String, Boolean, Boolean, TextJustification, ObjectAttributes)

Adds an annotation text object to the document.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddText(
	string text,
	Plane plane,
	double height,
	string fontName,
	bool bold,
	bool italic,
	TextJustification justification,
	ObjectAttributes attributes
)

Parameters

text
Type: SystemString
Text string.
plane
Type: Rhino.GeometryPlane
Plane of text.
height
Type: SystemDouble
Height of text.
fontName
Type: SystemString
Name of FontFace.
bold
Type: SystemBoolean
Bold flag.
italic
Type: SystemBoolean
Italic flag.
justification
Type: Rhino.GeometryTextJustification
The justification of the text.
attributes
Type: Rhino.DocObjectsObjectAttributes
Attributes to link to the object.

Return Value

Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
See Also