Click or drag to resize

File3dmObjectTableAddLine Method (Point3d, Point3d, ObjectAttributes)

Adds a line object to Rhino.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddLine(
	Point3d from,
	Point3d to,
	ObjectAttributes attributes
)

Parameters

from
Type: Rhino.GeometryPoint3d
The start point of the line.
to
Type: Rhino.GeometryPoint3d
The end point of the line.
attributes
Type: Rhino.DocObjectsObjectAttributes
Attributes to apply to line.

Return Value

Type: Guid
A unique identifier for the object.
See Also