Click or drag to resize

File3dmObjectTableAddLeader Method (String, Plane, IEnumerablePoint2d)

Adds an annotation leader to the document.

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddLeader(
	string text,
	Plane plane,
	IEnumerable<Point2d> points
)

Parameters

text
Type: SystemString
The text.
plane
Type: Rhino.GeometryPlane
A plane.
points
Type: System.Collections.GenericIEnumerablePoint2d
A list, an array or any enumerable set of 2d points.

Return Value

Type: Guid
A unique identifier for the object; or Empty on failure.
See Also