Click or drag to resize

File3dmLayerTable Class

Provides access to layers in the 3dm file.
Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableLayer
    Rhino.FileIOFile3dmCommonComponentTableLayer
      Rhino.FileIOFile3dmLayerTable

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class File3dmLayerTable : File3dmCommonComponentTable<Layer>, 
	IList<Layer>, ICollection<Layer>, IEnumerable<Layer>, 
	IEnumerable

The File3dmLayerTable type exposes the following members.

Properties
Methods
  NameDescription
Public methodAddDefaultLayer
Easy way to add a default layer to the model.
Public methodAddLayer(String, Color)
Easy way to add a new layer to the model.
Public methodAddLayer(String, Color, Guid)
Add a new layer to the model.
Public methodFindIndex
Retrieves a Layer object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodFindName
Finds a Layer given its name.
Public methodFindNameHash
Finds a Layer given its name hash.
Top
See Also