File3dmLayerTable Methods |
The File3dmLayerTable type exposes the following members.
Name | Description | |
---|---|---|
AddDefaultLayer |
Easy way to add a default layer to the model.
| |
AddLayer(String, Color) |
Easy way to add a new layer to the model.
| |
AddLayer(String, Color, Guid) |
Add a new layer to the model.
FindId |
Uses the guid to find a model component. Deleted objects cannot be found by id.
The guid is the value that is stored in the .Id property.
In a single document, no two active objects have the same guid. If an object is
replaced with a new object, then the guid persists. For example, if the _Move command
moves an object, then the moved object inherits its guid from the starting object.
If the Copy command copies an object, then the copy gets a new guid. This guid persists
FindIndex |
Retrieves a Layer object based on Index. This search type of search is discouraged.
We are moving towards using only IDs for all tables.
| |
FindName |
Finds a Layer given its name.
| |
FindNameHash |
Finds a Layer given its name hash.