Click or drag to resize

ObjectTableAddLinearDimension Method (LinearDimension, ObjectAttributes)

Adds a linear dimension object to the document.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddLinearDimension(
	LinearDimension dimension,
	ObjectAttributes attributes
)

Parameters

dimension
Type: Rhino.GeometryLinearDimension
Dimension object to add.
attributes
Type: Rhino.DocObjectsObjectAttributes

[Missing <param name="attributes"/> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddLinearDimension(Rhino.Geometry.LinearDimension,Rhino.DocObjects.ObjectAttributes)"]

Return Value

Type: Guid
The Guid of the newly added object or Guid.Empty on failure.
See Also