Click or drag to resize

ObjectTableAddClippingPlane Method (Plane, Double, Double, IEnumerableGuid, ObjectAttributes)

Adds a clipping plane object to Rhino.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddClippingPlane(
	Plane plane,
	double uMagnitude,
	double vMagnitude,
	IEnumerable<Guid> clippedViewportIds,
	ObjectAttributes attributes
)

Parameters

plane
Type: Rhino.GeometryPlane
The plane value.
uMagnitude
Type: SystemDouble
The size in the U direction.
vMagnitude
Type: SystemDouble
The size in the V direction.
clippedViewportIds
Type: System.Collections.GenericIEnumerableGuid
A list, an array or any enumerable set of viewport IDs that the new clipping plane will clip.
attributes
Type: Rhino.DocObjectsObjectAttributes
Document attributes for the plane.

Return Value

Type: Guid
A unique identifier for the object.
See Also