Click or drag to resize

ObjectTableAddSphere Method (Sphere, ObjectAttributes, HistoryRecord, Boolean)

[Missing <summary> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddSphere(Rhino.Geometry.Sphere,Rhino.DocObjects.ObjectAttributes,Rhino.DocObjects.HistoryRecord,System.Boolean)"]

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Guid AddSphere(
	Sphere sphere,
	ObjectAttributes attributes,
	HistoryRecord history,
	bool reference
)

Parameters

sphere
Type: Rhino.GeometrySphere

[Missing <param name="sphere"/> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddSphere(Rhino.Geometry.Sphere,Rhino.DocObjects.ObjectAttributes,Rhino.DocObjects.HistoryRecord,System.Boolean)"]

attributes
Type: Rhino.DocObjectsObjectAttributes

[Missing <param name="attributes"/> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddSphere(Rhino.Geometry.Sphere,Rhino.DocObjects.ObjectAttributes,Rhino.DocObjects.HistoryRecord,System.Boolean)"]

history
Type: Rhino.DocObjectsHistoryRecord

[Missing <param name="history"/> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddSphere(Rhino.Geometry.Sphere,Rhino.DocObjects.ObjectAttributes,Rhino.DocObjects.HistoryRecord,System.Boolean)"]

reference
Type: SystemBoolean

[Missing <param name="reference"/> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddSphere(Rhino.Geometry.Sphere,Rhino.DocObjects.ObjectAttributes,Rhino.DocObjects.HistoryRecord,System.Boolean)"]

Return Value

Type: Guid

[Missing <returns> documentation for "M:Rhino.DocObjects.Tables.ObjectTable.AddSphere(Rhino.Geometry.Sphere,Rhino.DocObjects.ObjectAttributes,Rhino.DocObjects.HistoryRecord,System.Boolean)"]

See Also