Click or drag to resize

RenderMaterialStandardChildSlots Enumeration

Defines enumerated constant values for use in TextureChildSlotName(RenderMaterialStandardChildSlots) method. NOTE WELL - these values cannot be changed. https://mcneel.myjetbrains.com/youtrack/issue/RH-57752

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.1
Syntax
public enum StandardChildSlots
Members
  Member nameValueDescription
None0 Corresponds to CRhRdkMaterial::ChildSlotUsage::None.
Diffuse100 Corresponds to CRhRdkMaterial::ChildSlotUsage::Diffuse.
Transparency101 Corresponds to CRhRdkMaterial::ChildSlotUsage::Transparency
Bump102 Corresponds to CRhRdkMaterial::ChildSlotUsage::Bump
Environment103 Corresponds to CRhRdkMaterial::ChildSlotUsage::Environment
PbrBaseColor100 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_base_color
PbrSubsurface104 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_subsurface
PbrSubSurfaceScattering105 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_subsurface_scattering_color
PbrSubsurfaceScatteringRadius106 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_subsurface_scattering_radius
PbrMetallic107 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_metallic
PbrSpecular108 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_specular
PbrSpecularTint109 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_specular_tint
PbrRoughness110 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_roughness
PbrAnisotropic111 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_anisotropic
PbrAnisotropicRotation112 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_anisotropic_rotation
PbrSheen113 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_sheen
PbrSheenTint114 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_sheen_tint
PbrClearcoat115 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_clearcoat
PbrClearcoatRoughness116 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_clearcoat_roughness
PbrOpacityIor117 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_opacity_ior
PbrOpacity101 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_opacity
PbrOpacityRoughness118 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_opacity_roughness
PbrEmission119 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_emission
PbrAmbientOcclusion120 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_ambient_occlusion
PbrDisplacement121 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_smudge
PbrClearcoatBump122 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_clearcoat_roughness
PbrAlpha123 Corresponds to CRhRdkMaterial::ChildSlotUsage::PBR_alpha
See Also