Click or drag to resize

RealtimeDisplayModeClassInfo Class

Class information obligatory for registering RealtimeDisplayMode implementations.
Inheritance Hierarchy
SystemObject
  Rhino.RenderRealtimeDisplayModeClassInfo

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RealtimeDisplayModeClassInfo

The RealtimeDisplayModeClassInfo type exposes the following members.

Constructors
  NameDescription
Protected methodRealtimeDisplayModeClassInfo
Initializes a new instance of the RealtimeDisplayModeClassInfo class
Top
Properties
  NameDescription
Public propertyDontRegisterAttributesOnStart
Override and return true when you don't want your class info to cause display attributes to be registered with the system.
Public propertyDrawOpenGl
Return true if the RealtimeDisplayMode draws its result using OpenGL. RenderWindow usage will then be skipped.
Public propertyGUID
Get the RealtimeDisplayMode implementation GUID
Public propertyName
Get human-facing class description for RealtimeDisplayMode implementation. This string might show up in the Rhino UI.
Public propertyRealtimeDisplayModeType
Get the type being registered.
Top
Methods
  NameDescription
Top
See Also