Click or drag to resize

Skylight Class

[Missing <summary> documentation for "T:Rhino.Render.Skylight"]

Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class Skylight : DocumentOrFreeFloatingBase, 
	IDisposable

The Skylight type exposes the following members.

Constructors
  NameDescription
Public methodSkylight
Create a utility object not associated with any document
Public methodSkylight(Skylight)
Create a utility object not associated with any document from another object
Top
Properties
  NameDescription
Public propertyCustomEnvironment Obsolete.
Public propertyCustomEnvironmentOn Obsolete.
Public propertyEnabled
Public propertyShadowIntensity
ShadowIntensity is currently unused.
Top
Methods
  NameDescription
Public methodCopyFrom (Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).)
Public methodDispose
Releases all resources used by the Skylight
Protected methodFinalize (Overrides FreeFloatingBaseFinalize.)
Top
Events
  NameDescription
Public eventStatic memberChanged
This event is raised when a Skylight property value is changed.
Top
See Also