Click or drag to resize

ImageFile Class

Controls interaction with RDK render image files
Inheritance Hierarchy
SystemObject
  Rhino.RenderImageFile

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class ImageFile

The ImageFile type exposes the following members.

Events
  NameDescription
Public eventStatic memberDeleted
Called when the RDK is cleaning up old render image files, a plug-in should delete any plug-in specific image files at this time.
Public eventStatic memberLoaded
Generally called when the "RenderOpenLastRender" command is run, this event is raised after the render window has been created and the saved scene has been loaded.
Public eventStatic memberSaved
Render image file saved, happens when a rendering completes. If a plug-in needs to save additional file information it should write it to the same folder as the Rhino render image file. Rhino will take care of deleting old data.
Top
See Also