Click or drag to resize

RenderSourceView Class

Helper class to get the correct view from the Render View Source settings. An instance of this class is supposed to be used with the using() {} construct.
Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderSourceView

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderSourceView : IDisposable

The RenderSourceView type exposes the following members.

Constructors
  NameDescription
Public methodRenderSourceView
Create a new RenderSourceView for the given doc. Note that this should be done with using(var rsv = new RenderSourceView(doc)) {} If the RenderSettings have the source view set to for instance a SnapShot this construct will ensure that the (active) view is set to the correct snapshot, and reverted back to the original once this instance goes out of scope.
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the RenderSourceView
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the RenderSourceView and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetViewInfo
Get the ViewInfo as specified by the render source view settings.
Top
See Also