Click or drag to resize

RenderPipeline Class

Provides facilities to a render plug-in for integrating with the standard Rhino render window. Also adds helper functions for processing a render scene. This is the suggested class to use when integrating a renderer with Rhino and maintaining a "standard" user interface that users will expect.
Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderPipeline

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RenderPipeline : IDisposable

The RenderPipeline type exposes the following members.

Constructors
  NameDescription
Protected methodRenderPipeline(RhinoDoc, RunMode, PlugIn, Size, String, RenderWindowStandardChannels, Boolean, Boolean)
Constructs a subclass of this object on the stack in your Rhino plug-in's Render() or RenderWindow() implementation.
Protected methodRenderPipeline(RhinoDoc, RunMode, PlugIn, Size, String, RenderWindowStandardChannels, Boolean, Boolean, AsyncRenderContext)
Constructs a subclass of this object on the stack in your Rhino plug-in's Render() or RenderWindow() implementation. This constructor should be used when a non-blocking RenderWindow is required. Note that the asynchronous render context will not be used when mode is Scripted.
Top
Properties
  NameDescription
Public propertyConfirmationSeconds
Sets the number of seconds that need to elapse during rendering before the user is asked if the rendered image should be saved.
Public propertyPlugIn
Public propertyRenderSessionId
Get the Id associated with this render session, this is useful when looking up Rhino.Render.RenderPanels.
Top
Methods
  NameDescription
Protected methodAddLightToScene
Protected methodAddRenderMeshToScene
Public methodCloseWindow
Closes the render window associated with this render instance.
Public methodCommandResult
Protected methodContinueModal
Frequently called during a rendering by the frame work in order to determine if the rendering should continue.
Public methodDispose
Releases all resources used by the RenderPipeline
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the RenderPipeline and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetRenderWindow
Get the RenderWindow associated with this RenderPipeline instance. This is virtual rather than abstract for V5 compat
Public methodGetRenderWindow(Boolean)
As GetRenderWindow(), but if withWireframeChannel is true the returned RenderWindow will have the channel added.
Public methodGetRenderWindow(Boolean, Boolean)
As GetRenderWindow(). The parameter withWireframeChannel controls whether the returned RenderWindow will have the channel added. The parameter fromRenderViewSource controls from where the RenderSize is queried.
Public methodGetRenderWindow(ViewportInfo, Boolean)
As GetRenderWindow(). The parameter withWireframeChannel controls whether the returned RenderWindow will have the channel added. The parameter fromRenderViewSource controls from where the RenderSize is queried. The viewportInfo instance will be used to set up wireframe channel. This is necessary for rendering different view than is currently active in the viewport
Public methodGetRenderWindow(ViewportInfo, Boolean, Rectangle)
As GetRenderWindow(). The parameter withWireframeChannel controls whether the returned RenderWindow will have the channel added. The parameter fromRenderViewSource controls from where the RenderSize is queried. The viewportInfo instance will be used to set up wireframe channel. This is necessary for rendering different view than is currently active in the viewport
Public methodGetRenderWindowFromRenderViewSource
Like GetRenderWindow(), but with the size for RenderWindow set from RenderViewSources if fromRenderViewSource is set to true
Protected methodIgnoreRhinoObject
Public methodStatic memberLocalizeRenderReturnCode
Protected methodNeedToProcessGeometryTable
Protected methodNeedToProcessLightTable
Protected methodOnRenderBegin
Called by the framework when it is time to start rendering, the render window will be created at this point and it is safe to start
Protected methodOnRenderBeginQuiet
Called by the framework when it is time to start rendering quietly, there is no user interface when rendering in this mode and the default post process effects will get applied to the scene when the rendering is complete.
Protected methodOnRenderEnd
Called by the framework when the user closes the render window or clicks on the stop button in the render window.
Protected methodOnRenderWindowBegin
Public methodPauseRendering
Implement to pause the current render session
Public methodRender
Call this function to render the scene normally. The function returns when rendering is complete (or cancelled).
Protected methodRenderEnterModalLoop
Protected methodRenderExitModalLoop
Protected methodRenderPreCreateWindow
Protected methodRenderSceneWithNoMeshes
Public methodStatic memberRenderSize Obsolete.
Public methodStatic memberRenderSize(RhinoDoc)
Get the render size as specified in the ON_3dmRenderSettings. Will automatically return the correct size based on the ActiveView or custom settings.
Public methodStatic memberRenderSize(RhinoDoc, Boolean)
Get the render size as specified in the ON_3dmRenderSettings, and from RenderSources when fromRenderSources is true.
Public methodRenderWindow
Call this function to render the scene in a view window. The function returns when rendering is complete (or cancelled).
Public methodResumeRendering
Implement to resume current render session
Public methodSaveImage
Saves the rendered image to a file. Does not prompt the user in any way.
Public methodSetAsyncRenderContext
Public methodSupportsPause
Override and return true if the renderer supports pausing
Top
See Also