Click or drag to resize

RenderTexture Class

[Missing <summary> documentation for "T:Rhino.Render.RenderTexture"]

Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RenderTexture : RenderContent

The RenderTexture type exposes the following members.

Constructors
  NameDescription
Protected methodRenderTexture
Initializes a new instance of the RenderTexture class
Top
Properties
  NameDescription
Public propertyLocalMappingTransform
Gets the transformation that can be applied to the UVW vector to convert it from normalized texture space into locally mapped space (ie - with repeat, offset and rotation applied.)
Public propertyPixelSize2
Override to provide details on the actual pixel sizes of this texture in UVW directions return null if the texture should not be treated as a bitmap.
Public propertyRenderHashWithoutLocalMapping
Render hash for texture excluding local mapping.
Public propertyRenderHashWithoutLocalMappingOrLinearWorkflow
Render hash for texture excluding local mapping and linear workflow.
Top
Methods
  NameDescription
Public methodCreateEvaluator Obsolete.
Constructs a texture evaluator. This is an independent lightweight object capable of evaluating texture color throughout uvw space. May be called from within a rendering shade pipeline.
Public methodCreateEvaluator(RenderTextureTextureEvaluatorFlags)
Constructs a texture evaluator. This is an independent lightweight object capable of evaluating texture color throughout uvw space. May be called from within a rendering shade pipeline.
Protected methodDispose(Boolean)
Protected methodFinalize
Public methodGenerateTextureSimulation
Public methodGetDisplayInViewport
Public methodGetEnvironmentMappingMode
Public methodStatic memberGetEnvironmentMappingProjection
Public methodGetInternalEnvironmentMappingMode
Public methodGetLocalMappingType
Public methodGetMappingChannel
Public methodGetOffset
Get offset value across UVW space. If the projection type is WCS or other type specified in model units, then this is the offset in meters.
Public methodGetOffsetLocked
Public methodGetPreviewIn3D
Public methodGetPreviewLocalMapping
Public methodStatic memberGetProceduralAaltonenNoiseArrayPointer
Public methodStatic memberGetProceduralAaltonenNoiseArraySize
Public methodStatic memberGetProceduralImpulseNoiseArrayPointer
Public methodStatic memberGetProceduralImpulseNoiseArraySize
Public methodStatic memberGetProceduralPerlinNoiseArrayPointer
Public methodStatic memberGetProceduralPerlinNoiseArraySize
Public methodStatic memberGetProceduralVcNoiseArrayPointer
Public methodStatic memberGetProceduralVcNoiseArraySize
Public methodGetProjectionMode
Public methodGetRepeat
Get repeat value across UVW space. If the projection type is WCS or other type specified in model units, then this is the repeat across 1 meter of the model.
Public methodGetRepeatLocked
Public methodGetRotation
Public methodStatic memberGetWcsBoxMapping
Public methodGetWrapType
Public methodGraphInfo
Public methodIsHdrCapable
Return true if the texture is HDR capable. When creating a custom RenderTexture implementation that is HDR capable set the appropriate property on the CustomRenderContentAttribute decorator on that clas.
Public methodIsImageBased
Query if the texture is image based. When creating a custom RenderTexture implementation of an image-based texture set the appropriate property on the CustomRenderContentAttribute decorator on that class. Do not override this function
Public methodIsLinear
Return true if the texture color data is linear. NOTE: this function is marked as virtual, but the correct way to make a custom RenderTexture linear is by setting the correct property for the CustomRenderContentAttribute decorator on the class.
Public methodIsNormalMap
Return true if the texture is a normalmap. When creating a custom RenderTexture implementation of a normal map set the appropriate property on the CustomRenderContentAttribute decorator on that clas.
Protected methodModifyRenderContentStyles
Public methodStatic memberNewBitmapTexture(SimulatedTexture) Obsolete.
Constructs a new basic texture from a SimulatedTexture.
Public methodStatic memberNewBitmapTexture(Bitmap, RhinoDoc)
Constructs a new basic texture from a Bitmap.
Public methodStatic memberNewBitmapTexture(SimulatedTexture, RhinoDoc)
Constructs a new basic texture from a SimulatedTexture.
Public methodPixelSize
Get the texture dimensions for the RenderTexture.
Public methodSaveAsImage
Save texture as image
Public methodSetDisplayInViewport(Boolean)
Public methodSetDisplayInViewport(Boolean, RenderContentChangeContexts)
Public methodSetEnvironmentMappingMode(TextureEnvironmentMappingMode)
Public methodSetEnvironmentMappingMode(TextureEnvironmentMappingMode, RenderContentChangeContexts)
Public methodSetGraphInfo
Public methodSetMappingChannel
Public methodSetOffset
Set offset value across UVW space. If the projection type is WCS or other type specified in model units, then this is the offset in meters.
Public methodSetOffsetLocked
Public methodSetPreviewIn3D
Public methodSetPreviewLocalMapping(Boolean)
Public methodSetPreviewLocalMapping(Boolean, RenderContentChangeContexts)
Public methodSetProjectionMode
Public methodSetRepeat
Set repeat value across UVW space. If the projection type is WCS or other type specified in model units, then this is the repeat across 1 meter of the model.
Public methodSetRepeatLocked
Public methodSetRotation
Public methodSetWrapType
Public methodSimulatedTexture
Public methodSimulateTexture(SimulatedTexture, Boolean) Obsolete.
Public methodSimulateTexture(SimulatedTexture, RenderTextureTextureGeneration, Int32, RhinoObject)
Top
See Also