RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Render
RenderContent Class
RenderContent Methods
AddAutomaticUserInterfaceSection Method
AddChild Method
AddPersistentRenderContent Method
AddUserInterfaceSection Method
BeginChange Method
BeginCreateDynamicFields Method
BindParameterToField Method
CalculateRenderHash Method
CalculateRenderHash2 Method
ChangeChild Method
ChildSlotAmount Method
ChildSlotNameFromParamName Method
ChildSlotOn Method
ConvertUnits Method
Create Method
CreateDynamicField Method
DeleteAllChildren Method
DeleteChild Method
Dispose Method
DynamicIcon Method
Edit Method
EndChange Method
EndCreateDynamicFields Method
Factory Method
Finalize Method
FindChild Method
ForDisplay Method
FromId Method
FromXml Method
GenerateQuickContentPreview Method
GenerateRenderContentPreview Method
GetChildSlotParameter Method
GetEmbeddedFilesList Method
GetExtraRequirementParameter Method
GetParameter Method
GetUiHash Method
GetUnderlyingInstances Method
Icon Method
Initialize Method
IsCompatible Method
IsContentTypeAcceptableAsChild Method
IsFactoryProductAcceptableAsChild Method
IsReference Method
IsRenderHashCached Method
LoadFromFile Method
MakeCopy Method
MakeGroupInstance Method
MatchData Method
ModifyRenderContentStyles Method
NewPreviewSceneServer Method
OnAddUserInterfaceSections Method
OnGetDefaultsInteractive Method
OnMakeCopy Method
OpenInEditor Method
OpenInModalEditor Method
ParamNameFromChildSlotName Method
RegisterContent Method
RenderHashExclude Method
Replace Method
SaveToFile Method
SetChild Method
SetChildSlotAmount Method
SetChildSlotOn Method
SetChildSlotParameter Method
SetExtraRequirementParameter Method
SetIsRenderHashRecursive Method
SetName Method
SetParameter Method
SetRenderHash Method
SmartUngroupRecursive Method
Ungroup Method
UngroupRecursive Method
Uninitialize Method
UseCount Method
VirtualIcon Method
RenderContent
EndChange Method
Ends a change or batch of changes. Calls to this method are counted; you must call this method once for every call to
BeginChange(RenderContent
ChangeContexts)
. Note: If
BeginChange(RenderContent
ChangeContexts)
was called with ChangeContexts.UI, ChangeContexts.Program, ChangeContexts.Drop or ChangeContexts.UI.Tree and Changed() was called between the calls to
BeginChange(RenderContent
ChangeContexts)
and EndChange(), the last call to EndChange() will raise the
ContentChanged
event.
Namespace:
Rhino.Render
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
6.0
Syntax
C#
VB
Copy
public
void
EndChange
()
Public
Sub
EndChange
See Also
Reference
RenderContent Class
Rhino.Render Namespace
Rhino 8.12.24282.07000 (2024-10-08)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com