Click or drag to resize

RenderTextureGetEnvironmentMappingProjection Method

[Missing <summary> documentation for "M:Rhino.Render.RenderTexture.GetEnvironmentMappingProjection(Rhino.Render.TextureEnvironmentMappingMode,Rhino.Geometry.Vector3d,System.Single@,System.Single@)"]

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.7
Syntax
public static bool GetEnvironmentMappingProjection(
	TextureEnvironmentMappingMode mode,
	Vector3d reflectionVector,
	out float u,
	out float v
)

Parameters

mode
Type: Rhino.RenderTextureEnvironmentMappingMode

[Missing <param name="mode"/> documentation for "M:Rhino.Render.RenderTexture.GetEnvironmentMappingProjection(Rhino.Render.TextureEnvironmentMappingMode,Rhino.Geometry.Vector3d,System.Single@,System.Single@)"]

reflectionVector
Type: Rhino.GeometryVector3d

[Missing <param name="reflectionVector"/> documentation for "M:Rhino.Render.RenderTexture.GetEnvironmentMappingProjection(Rhino.Render.TextureEnvironmentMappingMode,Rhino.Geometry.Vector3d,System.Single@,System.Single@)"]

u
Type: SystemSingle

[Missing <param name="u"/> documentation for "M:Rhino.Render.RenderTexture.GetEnvironmentMappingProjection(Rhino.Render.TextureEnvironmentMappingMode,Rhino.Geometry.Vector3d,System.Single@,System.Single@)"]

v
Type: SystemSingle

[Missing <param name="v"/> documentation for "M:Rhino.Render.RenderTexture.GetEnvironmentMappingProjection(Rhino.Render.TextureEnvironmentMappingMode,Rhino.Geometry.Vector3d,System.Single@,System.Single@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Render.RenderTexture.GetEnvironmentMappingProjection(Rhino.Render.TextureEnvironmentMappingMode,Rhino.Geometry.Vector3d,System.Single@,System.Single@)"]

See Also