Click or drag to resize

RenderWindowChannelGPU Class

[Missing <summary> documentation for "T:Rhino.Render.RenderWindow.ChannelGPU"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderWindowChannelGPU

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ChannelGPU : IDisposable

The RenderWindowChannelGPU type exposes the following members.

Properties
  NameDescription
Public propertyDisplayTechnology
Return the type of API used for this channel's texture handle.
Top
Methods
  NameDescription
Public methodClone
Return a clone of the channel.
Public methodClose
Close the channel.
Public methodCopyTo
Copy the channel to a 'CPU' channel.
Public methodDispose
Dispose of the channel.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodHeight
Return the channel height.
Public methodId
Return the channel id.
Public methodPixelSize
Return the size of one pixel's data in the channel.
Public methodTextureHandle Obsolete.
Return the channel's texture handle.
Public methodTextureHandleMetal
Return the channel's Metal texture handle (id<MTLTexture>) as an IntPtr. If there isn't one, IntPtr.Zero will be returned. The ChannelGPU.DisplayTechnology property will indicate which type of texture is stored in the channel. The IntPtr can be turned back into an Objective-C id<MTLTexture> using id<MTLTexture> texture = CFBridgingRelease(ptr);
Public methodTextureHandleOpenGL
Return the channel's OpenGL texture handle. If there isn't one, a value of 0 will be returned. The ChannelGPU.DisplayTechnology property will indicate which type of texture is stored in the channel.
Public methodWidth
Return the channel width.
Top
See Also