Click or drag to resize

CustomRenderMeshProvider Class

Note: This API is now obsolete.

You must call CustomRenderMeshProvider.RegisterProviders() from your plug-ins OnLoad override for each assembly containing a custom mesh provider. Only publicly exported classes derived from CustomRenderMeshProvider with a public constructor that has no parameters will get registered.
Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[ObsoleteAttribute]
public abstract class CustomRenderMeshProvider

The CustomRenderMeshProvider type exposes the following members.

Constructors
  NameDescription
Protected methodCustomRenderMeshProvider
Default constructor
Top
Properties
  NameDescription
Public propertyStatic memberCurvePipingId
Public propertyStatic memberDisplacementId
Public propertyStatic memberEdgeSofteningId
Public propertyName
The name of the provider for UI display.
Public propertyStatic memberShutLiningId
Public propertyStatic memberThickeningId
Top
Methods
  NameDescription
Public methodStatic memberAllObjectsChanged Obsolete.
Call this method if your render meshes change.
Public methodStatic memberAllObjectsChanged(RhinoDoc)
Call this method if your render meshes change.
Public methodBoundingBox(ViewportInfo, RhinoObject, Guid, Boolean)
Returns a bounding box for the custom render meshes for the given object.
Public methodBoundingBox(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes)
Public methodBuildCustomMeshes
Build custom render mesh(es).
Public methodStatic memberDocumentBasedMeshesChanged
Public methodStatic memberObjectChanged
Public methodStatic memberRegisterProviders
Call this method once from your plug-ins OnLoad override for each assembly containing a custom mesh provider. Only publicly exported classes derived from CustomRenderMeshProvider with a public constructor that has no parameters will get registered.
Public methodWillBuildCustomMeshes
Determines if custom render meshes will be built for a particular object.
Top
See Also