Click or drag to resize

TextureSpace Enumeration

Texture space When a mapping primitive is a box or a capped cylinder, there are two options for the mapping. Either the sides all map to (0,1)x(0,1) (so the either texture map appears on each side, or the sides map to distinct regions of the texture space.

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum TextureSpace
Members
  Member nameValueDescription
Single0 sides and caps map to same texture space
Divided1 regions of texture space. (0, 1/4, 2/4, 3/4, 1) for uncapped boxes. (0, 1/6, 2/6, 3/6, 4/6, 5/6, 1) for capped boxes. (0, 4/6, 5/6, 1) for capped cylinders.
See Also