Click or drag to resize

GroundPlane Class

Represents an infinite plane for implementation by renderers. See SupportsFeature.
Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class GroundPlane : DocumentOrFreeFloatingBase, 
	IDisposable

The GroundPlane type exposes the following members.

Constructors
  NameDescription
Public methodGroundPlane
Create a utility object not associated with any document
Public methodGroundPlane(GroundPlane)
Create a utility object not associated with any document from another object
Top
Properties
  NameDescription
Public propertyAltitude
Height above world XY plane in model units. Auto-altitude is computed if enabled.
Public propertyAutoAltitude
Determines whether the ground plane is fixed by the Altitude property, or whether it is automatically placed at the lowest point in the model.
Public propertyEnabled
Determines whether the document ground plane is enabled.
Public propertyMaterialInstanceId
Id of material in material table for this ground plane.
Public propertyShadowOnly
Determines whether the ground plane shows the material assigned, or whether it is transparent, but captures shadows.
Public propertyShowUnderside
If this is off, the ground plane will not be visible when seen from below.
Public propertyTextureOffset
Texture mapping offset in world units.
Public propertyTextureOffsetLocked
Texture offset locked.
Public propertyTextureRotation
Texture mapping rotation around world origin + offset in degrees.
Public propertyTextureSize
Texture mapping single UV span size in world units.
Public propertyTextureSizeLocked
Texture size locked.
Top
Methods
  NameDescription
Public methodCopyFrom (Overrides FreeFloatingBaseCopyFrom(FreeFloatingBase).)
Public methodDispose
Releases all resources used by the GroundPlane
Protected methodFinalize (Overrides FreeFloatingBaseFinalize.)
Top
Events
  NameDescription
Public eventStatic memberChanged
This event is raised when a GroundPlane property value is changed.
Top
See Also