Click or drag to resize

RenderWindowChannel Class

[Missing <summary> documentation for "T:Rhino.Render.RenderWindow.Channel"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderWindowChannel

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Channel : IDisposable

The RenderWindowChannel type exposes the following members.

Properties
  NameDescription
Public propertyHeight
Return the channel height.
Public propertyId
Return the channel id.
Public propertyWidth
Return the channel width.
Top
Methods
  NameDescription
Public methodAddValue
Add value to existing values at point x, y. If x or y are out of range, the function will fail and may crash Rhino.
Public methodClone
Return a clone of the channel.
Public methodDispose
Releases all resources used by the RenderWindowChannel
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the RenderWindowChannel and optionally releases the managed resources
Public methodGetMinMaxValues
Get the minimum and maximum values in the channel. minThe channel's minimum value. maxThe channel's maximum value.
Public methodGetValue
Get values from the channel.
Public methodGetValues
Get a rectangle of values from the channel. The input parameters are checked for validity. If the rectangle is not fully inside the frame buffer, the function will fail.
Public methodPixelSize
Returns the size of the data in one pixel in the channel. For RDK standard channels, this value is always sizeof(float). For the special chanRGBA collective channel, this value is 4 * sizeof(float).
Public methodSetValue(Int32, Int32, Color4f)
If x or y are out of range, the function will fail and may crash Rhino.
Public methodSetValue(Int32, Int32, Single)
Assign value to a pixel at coordinate (x, y).
Public methodSetValues
Set a pixel buffer
Public methodSetValuesFlipped
Set a pixel buffer y-flipped.
Top
See Also