Click or drag to resize

Projection Enumeration

When a mapping primitive, like a plane, sphere, box, or cylinder, is used, there are two projection options. If m_type = srfp_mapping, then m_projection is ignored.

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum Projection
Members
  Member nameValueDescription
None0 None
ClosestPoint1 ClosestPoint: world xyz maps to the point on the mapping primitive that is closest to xyz. In this case, ON_TextureMapping::Evaluate ignores the vector argument.
Ray2 Ray: world xyz + world vector defines a world line. The world line is intersected with the mapping primitive and the intersection point that is closest to the world xyz point is used to calculate the mapping parameters.
See Also