Click or drag to resize

SceneServerData Class

The Scene Server Data used by the PreviewSceneServer
Inheritance Hierarchy
SystemObject
  Rhino.RenderSceneServerData

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SceneServerData : IDisposable

The SceneServerData type exposes the following members.

Constructors
  NameDescription
Public methodSceneServerData(PreviewAppearance, SceneServerDataUsage)
Initializes a new instance of the SceneServerData class
Public methodSceneServerData(PreviewGeometry, PreviewBackground, PreviewLighting, SceneServerDataUsage) Obsolete.
Constructor for SceneServerData
Top
Properties
  NameDescription
Public propertyCppPointer
The CppPointer of SceneServerData
Top
Methods
  NameDescription
Public methodDispose
Dispose for SceneServerData
Protected methodDispose(Boolean)
Dispose for SceneServerData
Protected methodFinalize
Destructor for SceneServerData
(Overrides ObjectFinalize.)
Top
See Also