Click or drag to resize

RenderPrimitiveList Class

Note: This API is now obsolete.

[Missing <summary> documentation for "T:Rhino.Render.RenderPrimitiveList"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderPrimitiveList

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[ObsoleteAttribute("Use RenderPrimitives")]
public class RenderPrimitiveList : IDisposable

The RenderPrimitiveList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Number of meshes in this list
Public propertyRhinoObject
The Rhino object associated with this list
Public propertyUseObjectsMappingChannels
Returns true if the texture mapping will be taken from the Rhino object otherwise; the texture mapping will use the texture coordinates on the mesh only.
Top
Methods
  NameDescription
Public methodAdd(Box, RenderMaterial)
Add primitive box and material.
Public methodAdd(IEnumerableMesh, RenderMaterial)
Public methodAdd(Mesh, RenderMaterial)
Add mesh and material.
Public methodAdd(PlaneSurface, RenderMaterial)
Add primitive plane and material.
Public methodAdd(Sphere, RenderMaterial)
Add primitive sphere and material.
Public methodAdd(Cone, Plane, RenderMaterial)
Add primitive cone and material.
Public methodAdd(Mesh, RenderMaterial, Transform)
Add mesh and material.
Public methodAutoDeleteMaterialsOn
Public methodAutoDeleteMeshesOn
Public methodClear
Remove all primitives from this list
Public methodConvertMeshesToTriangles
Convert mesh quad faces to triangle faces.
Public methodDispose
Releases all resources used by the RenderPrimitiveList
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetInstanceTransform
Public methodMaterial
Call this method to get the render material associated with the mesh at the specified index. Will return null if there is no material associated with the requested mesh.
Public methodMesh
Get the mesh for the primitive at the specified index. If the item at this index is a primitive type other than a mesh then it mesh representation is returned.
Public methodMeshInstance
Get the mesh for the primitive at the specified index. If the item at this index is a primitive type other than a mesh then it mesh representation is returned.
Public methodPrimitiveType
Type of primitive object at this index.
Public methodSetInstanceTransform
Public methodToMaterialArray
Call this method to see if there are any RenderMaterials associated with the meshes. Each primitive can optionally have a RenderMaterial associated with it, if the RenderMaterial is null then check for a RhinoObject.RenderMaterial.
Public methodToMeshArray
Call this method to get a array of meshes, all primitives will get meshed and the meshes will get included in the returned array.
Public methodTryGetBox
Call this method to get a box at the specified index.
Public methodTryGetCone
Call this method to get a box at the specified index.
Public methodTryGetPlane
Call this method to get a box at the specified index.
Public methodTryGetSphere
Call this method to get a box at the specified index.
Top
See Also