Click or drag to resize

RenderPrimitiveListAdd Method (Cone, Plane, RenderMaterial)

Add primitive cone and material.

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.7
Syntax
public void Add(
	Cone cone,
	Plane truncation,
	RenderMaterial material
)

Parameters

cone
Type: Rhino.GeometryCone
Cone to add.
truncation
Type: Rhino.GeometryPlane
The plane used to cut the cone (the non-apex end is kept). Should be equal to cone.plane if not truncated.
material
Type: Rhino.RenderRenderMaterial
Material to add, may be null if not needed.
See Also