Click or drag to resize

ContentUndoHelper Class

Content undo helper to be used with "using {}" to enclose a block of changes.
Inheritance Hierarchy
SystemObject
  Rhino.RenderContentUndoHelper

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ContentUndoHelper : IDisposable

The ContentUndoHelper type exposes the following members.

Constructors
  NameDescription
Public methodContentUndoHelper(RhinoDoc)
Constructs a ContentUndoHelper object inside a using block to handle undo when modifying a RenderContent or - alternatively - create the ContentUndoHelper and explicitly call Dispose when you are done.
Public methodContentUndoHelper(RhinoDoc, String) Obsolete.
DEPRECATED: Constructs a ContentUndoHelper object inside a using block to handle undo when modifying a RenderContent or - alternatively - create the ContentUndoHelper and explicitly call Dispose when you are done.
Top
Methods
  NameDescription
Public methodAddContent
Call this *after* adding a content. Undo will cause the content to be deleted.
Public methodDispose
Releases all resources used by the ContentUndoHelper
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the ContentUndoHelper and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodModifyContent
Call this before modifying or deleting a content. Undo will cause the content to be restored.
Public methodTweakContent
Call this before tweaking a single content parameter. Undo will cause the parameter to be restored.
Top
See Also