Click or drag to resize

PreviewAppearance Class

PreviewAppearance class
Inheritance Hierarchy
SystemObject
  Rhino.RenderPreviewAppearance

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class PreviewAppearance : IDisposable

The PreviewAppearance type exposes the following members.

Constructors
  NameDescription
Public methodPreviewAppearance
Constructor for previewappearance
Top
Properties
  NameDescription
Public propertyCppPointer
Previewappearances c++ pointer
Public propertyMetaData
Previewappearance MetaData
Public propertyScale
Size - used in the UI. Always meters.
Public propertySceneScale
Scene size - the actual size that is rendered
Top
Methods
  NameDescription
Public methodBackground
Background
Public methodDispose
Dispose for previewappearance
Protected methodFinalize
Destructor for previewappearance
(Overrides ObjectFinalize.)
Public methodFromMetaData
Copy data from MetaData to PreviewAppearance
Public methodGeometry
Geometry
Public methodLighting
Lighting
Public methodRotationType
RotationType
Public methodRotationX
RotationX
Public methodRotationY
RotationY
Public methodSetRotationType
SetRotationType
Public methodSetRotationX
SetRotationX
Public methodSetRotationY
SetRotationY
Public methodSetSize Obsolete.
SetSize
Public methodSize Obsolete.
Size - used in the UI. Always meters.
Public methodToMetaData
Copy PreviewAppearance to MetaData
Public methodToMetaData(MetaDataProxy)
Copy PreviewAppearance to MetaData
Top
See Also