Click or drag to resize

Utilities Class

[Missing <summary> documentation for "T:Rhino.Render.Utilities"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderUtilities

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class Utilities

The Utilities type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberDefaultRenderPlugInId
Get the plug-in Id for the default render plug-in
Public propertyStatic memberShowIncompatibleEnvironments
Specifies whether incompatible content should be shown in the corresponding editor.
Public propertyStatic memberShowIncompatibleMaterials
Specifies whether incompatible content should be shown in the corresponding editor.
Public propertyStatic memberShowIncompatibleTextures
Specifies whether incompatible content should be shown in the corresponding editor.
Top
Methods
  NameDescription
Public methodStatic memberChangeContentType
Changes the type of a content. This deletes the content and creates a replacement of the specified type allowing the caller to decide about harvesting.
Public methodStatic memberFindFile(RhinoDoc, String)
Finds a file and also handles network shares.
Remarks
This is a replacement for CRhinoFileUtilities::FindFile().
Public methodStatic memberFindFile(RhinoDoc, String, Boolean)
Finds a file and also handles network shares.
Remarks
This is a replacement for CRhinoFileUtilities::FindFile().
Public methodStatic memberGetUnpackedFilesCacheFolder
Gets a folder associated with the document for unpacking textures to
Public methodStatic memberIsCachedTextureFileInUse
Determines if any texture in any persistent content list is using the specified file name for caching.
Public methodStatic memberLoadPersistentRenderContentFromFile
Loads a content from a library file and adds it to the persistent content list of a particular document.
Public methodStatic memberMoveWindow
Public methodStatic memberPromptForSaveImageFileParameters
Prompts the user for a save file name and the width, height and depth of an image to be saved.
Public methodStatic memberSafeFrameEnabled
Queries whether or not the Safe Frame is visible.
Public methodStatic memberSetDefaultRenderPlugIn
Set default render application
Public methodStatic memberShowContentChooser(Guid, Guid, RenderContentKind, Guid, RenderContentShowContentChooserFlags, RhinoDoc)
Shows the content chooser to allow the user to select a new or existing content.
Public methodStatic memberShowContentChooser(RhinoDoc, Guid, Guid, RenderContentKind, RenderContentShowContentChooserFlags, String, IEnumerableString, IEnumerableGuid, Guid)
Shows the content chooser to allow the user to select a new or existing content, or multiple contents.
Public methodStatic memberShowContentChooser(RhinoDoc, Guid, Guid, RenderContentKind, UtilitiesContentChooserFlags, String, IEnumerableString, IEnumerableGuid, Guid)
Shows the content chooser to allow the user to select a new or existing content, or multiple contents.
Public methodStatic memberShowIORMenu
Display and track the context menu.
Top
See Also