Click or drag to resize

LightManagerSupport Class

Base class for implementing custom light managers in .NET
Inheritance Hierarchy
SystemObject
  Rhino.RenderLightManagerSupport

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class LightManagerSupport

The LightManagerSupport type exposes the following members.

Constructors
  NameDescription
Protected methodLightManagerSupport
Default constructor
Top
Methods
  NameDescription
Public methodDeleteLight
Delete light
Public methodGetLights
Get all the lights that are associated to the light manager. The lights are added to the LightArray parameter passed to the GetLights method
Public methodGetLightSolo
Returns the value of "ON_LIght::m_bOn" if the light is in solo storage, or false if not in solo storage (ie - this is the checkbox state on the light manager dialog)
Public methodGroupLights
Creates a new group with the lights
Public methodLightDescription
Gets the string representation of the light description
Public methodLightFromId
Get Rhino.Geometry.Light object associated to Guig uuid
Public methodLightsInSoloStorage
Returns the number of lights in solo storage - any number other than 0 means "in solo mode"
Public methodModifyLight
Modify properties of the light
Public methodObjectSerialNumberFromLight
Get the object serial number of the light
Public methodOnCustomLightEvent
Generates LightMangerSupportCustomEvent: light_added, light_deleted, light_undeleted, light_modified, light_sorted, The event triggers a Light table event that the rdk lightmanager listens too
Public methodOnEditLight
The default implementation of OnEditLight selects the lights and opens the Lights Properties page
Public methodPluginId
The Guid of the plugin
Public methodStatic memberRegisterLightManager
Find and register classes that derive from LightManagerSupport from the given plug-in.
Public methodStatic memberRegisterProviders
Find and register classes that derive from RealtimeDisplayMode from the given plug-in. The plug-in is found in the given assembly
Public methodRenderEngineId
The Guid of the render engine
Public methodSetLightSolo
First checks to see if we are in "solo mode" - which means that there are any lights that respond "true" to IsInSoloStorage. If in solo mode: If bSolo = true Sets this light on. If bSolo = false If this is the last light "on", forces all lights out of solo mode. If there are other lights on, turns this light off. If not in solo mode: If bSolo = true Forces all lights into solo storage and sets this light on. If bSolo = false This shouldn't happen. Will cause an ASSERT
Public methodUnGroup
UnGroups the lights
Top
See Also