Click or drag to resize

PreviewJobSignature Class

Preview Job Signature is a specific identifier for a specific rendered preview
Inheritance Hierarchy
SystemObject
  Rhino.RenderPreviewJobSignature

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class PreviewJobSignature : IDisposable

The PreviewJobSignature type exposes the following members.

Constructors
  NameDescription
Public methodPreviewJobSignature
Preview Job Signature constructor
Public methodPreviewJobSignature(IntPtr)
Preview Job Signature constructor
Public methodPreviewJobSignature(Int32, Int32, UInt32)
Preview Job Signature constructor
Top
Properties
  NameDescription
Public propertyCppPointer
UnManaged pointer of the PreviewJobsingature
Top
Methods
  NameDescription
Public methodCompare
Compare two Preview Job Signatures. True if they are the same, otherwise false.
Public methodDispose
Dispose
Protected methodFinalize
Preview Job Signature destructor
(Overrides ObjectFinalize.)
Public methodImageHeight
The Height of the rendered preview image
Public methodImageWidth
The Width of the rendered preview image
Top
See Also