RenderContentKindList Class |
Namespace: Rhino.Render
The RenderContentKindList type exposes the following members.
Name | Description | |
---|---|---|
![]() | RenderContentKindList |
Construct an empty kind list
|
![]() | RenderContentKindList(IntPtr) |
Construct from native pointer - internal use only.
|
![]() | RenderContentKindList(RenderContentKindList) |
Construct a kind list from another.
|
Name | Description | |
---|---|---|
![]() | CppPointer |
Name | Description | |
---|---|---|
![]() | Add |
Add a kind to a kind list.
|
![]() | Contains |
Query whether or not the collection contains a particular kind designation.
|
![]() | Count |
The number of kinds in the collection
|
![]() | Dispose |
Dispose a kind list.
|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize |
Kind list finalizer
(Overrides ObjectFinalize.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | SingleKind |
The single kind in the list. If the list does not contain exactly one kind, returns 'None'.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |