Click or drag to resize

RenderWindow Class

[Missing <summary> documentation for "T:Rhino.Render.RenderWindow"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderWindow

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderWindow : IDisposable

The RenderWindow type exposes the following members.

Properties
  NameDescription
Public propertySessionId
Top
Methods
  NameDescription
Public methodAddChannel
Add a channel to the frame buffer in addition to the fixed Red, Green, Blue and Alpha channels.
Public methodAddWireframeChannel
This method sets the frame buffer size and adds all the necessary wireframe channels automatically. It also creates the wireframe channel data automatically so that your renderer doesn't have to. You typically call this method only when your renderer does not support wireframe rendering itself. If you call this method, then you should not add any wireframe channels returned by GetRenderChannels(). If your renderer is capable of rendering the wireframe channels itself, you should not call this method. Instead, you must make sure you add the wireframe channels if GetRenderChannels() requests them. See IRhRdkRenderWindow::GetRenderChannels(). After the wires are rendered, the wireframe post effects will composite them into the final rendered image. Note: This method should really be called AddWireframeChannels(). [SDK_UNFREEZE] */
Public methodStatic memberChannelId
Public methodStatic memberCreate
Public methodDispose
Releases all resources used by the RenderWindow
Public methodEndAsyncRender
Must be called when an asynchronous render has finished or ended for any reason.
Public methodStatic memberFromSessionId
Public methodGetAdjust Obsolete.
OBSOLETE. NOT IMPLEMENTED.
Public methodGetBitmap
Public methodGetRequestedRenderChannels
Get array of Guids representing the channels requested by the post effect pipeline for this RenderWindow.
Public methodGetRequestedRenderChannelsAsStandardChannels
Get array of StandardChannels enum values representing the channels requested by the post effect pipeline for this RenderWindow.
Public methodInvalidate
Invalidate the entire view window so that the pixels get painted.
Public methodInvalidateArea
Public methodIsChannelAvailable
Query if a channel is available.
Public methodIsChannelShown
Query if a channel is being shown.
Public methodOpenChannel
Public methodRegisterPostEffectExecutionControl
Register an instance of PostEffectExecutionControl.
Public methodSaveDibAsBitmap
Save current Dib of RenderWindow as file Helper function for debugging purposes.
Public methodSaveRenderImageAs(String, Boolean)
Like RenderWindow.SaveRenderImageAs(string,Guid,bool), but with Guid set to Guid.Empty.
Public methodSaveRenderImageAs(String, Guid, Boolean)
Save current RenderWindow contents as an image file with the given name. The filetype will be determine. Pass in render engine Guid if an engine implements saving to a format that is not supported by Rhino. Guid.Empty if there is no need for that.
Public methodSetAdjust Obsolete.
OBSOLETE. NOT IMPLEMENTED.
Public methodSetIsRendering
Set whether or not rendering is in progress. Added to support raytraced mode.
Public methodSetProgress
Accepts a rendering progress value to inform the user of the rendering advances.
Public methodSetRenderOutputRect
Specify a sub-rectangle of the render window to indicate where the relevant render output has been written. For example, if a renderer chooses to render at half resolution, it could write its data to the top left quadrant of the render window, which can be indicated by setting the render output rectangle. This is set to the full render window size by default. When the render window size is modified, the render output rectangle will be set to reflect the new size.
Public methodSetRGBAChannelColors(Rectangle, Color4f)
Call this method to open the RenderWindow.StandardChannels.RGBA channel and set a block of color values
Public methodSetRGBAChannelColors(Size, Color4f)
Call this method to open the RenderWindow.StandardChannels.RGBA channel and set a block of color values
Public methodSetSize
Public methodSetView
Public methodSize
Public methodStatic memberStandardChannelForGuid
Get the StandardChannels for the given Guid
Top
Events
  NameDescription
Public eventStatic memberCloned
Top
See Also