Click or drag to resize

RenderContentSerializer Class

Used to import and export custom render content such as materials, environments and textures. You must override RenderPlugIn.RenderContentSerializers() and return an array of derived RenderContentSerializer class types to add to the content browsers.
Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderContentSerializer

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RenderContentSerializer

The RenderContentSerializer type exposes the following members.

Constructors
  NameDescription
Protected methodRenderContentSerializer
Protected constructor to be called from derived class
Top
Properties
  NameDescription
Public propertyCanRead
If true then the file type can be imported and will be included in the file open box when importing the specified render content kind.
Public propertyCanWrite
If true then the file type can be exported and will be included in the file save box when exporting the specified render content kind.
Public propertyContentKind
Kind of content created when importing or exporting this file type - ie, Material, Texture or Environment
Public propertyContentType Obsolete.
Kind of content created when importing or exporting this file type. Obsolete - use ContentKind
Public propertyEnglishDescription
English string describing this plug-in
Public propertyFileExtension
File extension associated with this serialize object
Public propertyLocalDescription
Localized plug-in description
Top
Methods
  NameDescription
Public methodCanLoadMultiple
If true the plug-in is capable of loading multiple contents.
Public methodLoadMultiple
Create any number of new render contents loaded from any number of files.
Public methodRead
Called to when importing a file, file should be parsed and converted to a valid RenderContent object.
Public methodRegisterSerializer
Register the RenderContentSerializer
Public methodReportContentAndFile
This is called from your implementation of LoadMultiple() to add a content and the file it was loaded from when the LoadMultipleFlags.Preload flag is NOT set. See LoadMultiple() for an explanation of this method's use.
Public methodReportDeferredContentAndFile
This is called from your implementation of LoadMultiple() to add a 'deferred' content and the file it will be loaded from when the LoadMultipleFlags.Preload flag is set. See LoadMultiple() for an explanation of this method's use. \param c is the deferred content. \param wszFullPath is the full path to the file that 'c' will be loaded from. \param flags is reserved for future use; you should pass zero. \param pReserved is reserved for future use; you should pass nullptr. */
Public methodWrite
Called to save a custom RenderContent object as an external file.
Top
See Also